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The intended audience includes University of Oregon report writers who are developing Enterprise level 
reports with Cognos Report Studio. 

Report Standards Checklist 
 Page Header 

 Page Footer 

 Report Body Style  

 Report Body Pagination 

 Column Header Text 

 Report Body Headers 

 Data Formats 

 Prompt Page 

 Report Help 

 Comments Page 

 Drill-Through Links 

 Graphs 

 View as PDF 

 View as Excel 

 Versioning 

Terms to know 
Integrated Data & Reporting (IDR) integrates the University's information resources to support operational 
reporting and substantially improve efficiency in analysis and forecasting. Data is refreshed nightly so reports 
reflect the activity of the previous day. 
 
Cognos Report Studio is the most advanced report design tool in Cognos and is used for developing reports 

intended for the UO Enterprise report folders. 

Report Writers Collaboration folder is an area in Cognos that is available to all report writers for use during 

development of reports. 

Unlocking a Report  
To make changes to layout objects you may need to temporarily unlock the report. 

 Use the padlock  or from the Structure menu >> Lock Page Objects 

 Once the change has been made it is best to relock the report 

Page Header 
 Delete the ‘Double-click to edit text’ text item and leave the header block in place 

 Drag a table into the header block and make it 3 columns and 1 row.  This table will be the container for 

these items:  

o Column 1 – Report Name and high level parameter responses 
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o Column 2 – University of Oregon Logo 

o Column 3 – Drill-through links to Excel, PDF, or other reports 

 Select column 1. In Properties, Size & Overflow, set Width: 33%. 

 Select column 2. In Properties, Size & Overflow, set Width: 33%. 

 

 

Header Column 1 - Report Name and High-Level Parameter Responses 

 Report Name 

o Drag a table to column 1 and make it 1 column and enough rows to display pertinent header 

information. (3 rows in example for Budget Status report) 

o Row 1 is for the report name 

o Drag a text item into row 1 and type the report name.  The name should be the same report 

name that users see in the Enterprise Folders 

 Note: Do not use ReportName() formula because users change the name when saving a 

Report View 

o Font: Arial, 12 or 14 pt, bold. Use a font size that makes sense for the space 

o Left justify the cell 

o With cell selected, in Properties add Padding. Bottom: 3px 

 High-level parameter responses like Fiscal Year/Fiscal Period or Term/Semester  

o Row 2 is for the next most important item. In this example drag in a text item ‘Fiscal Year: ‘ plus 

the data item or expression ParamDisplayValue('p_FY') 

o Row 3 is for the next most important item. In this example ‘Fiscal Period: ‘ plus the data item or 

expression ParamDisplayValue('p_FP') 

o Font: Arial, 10 or 11 pt, regular 

o Left justify the cell 

 Note: Items to display in the header is based on common sense. Bring in those items needed to 

communicate what the report displays. Other parameter responses like FOAPAL elements that are used 

for groupings can be displayed in the report body headers, covered below. 

 For drill-through reports, always display the drill-through value in the headers of the target report to 

retain the context of the data.  For instance, if the user clicks Fund to drill-through then include Fund in 

the header. 

Header Column 2 - University of Oregon Logo  

 Drag an image object from the toolbox to column 2 in the header table 

 Double-click the image and the Image URL window appears 

 Click Browse 

 Select UOSignature-3455.jpg and click OK 
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  
 

 In Properties > Positioning > Size & Overflow, set the 

height to 60 px 

 Center justify the cell 

Header Column 3 - Drill-through links to Excel, PDF, or other reports 

 Drag a table to column 3 and make it 1 column and 3 rows 

 Add appropriate content starting in the lowest cell.  Content can include drill-throughs to special 

versions of Excel like the raw data flattened out version that users will not get if they simply chose to 

run/view the report as Excel.  Other content may be a special version of PDF or drill-throughs to other 

reports when a drill-through on a data item may not make sense.  

Page Footer  
A 3 column by 1 row table already exists in the default footer.  We will use it for the following: 

 Column 1 – Version number and date 

 Column 2 – Page number 

 Column 3 – Run date and time 

  

 

Footer Column 1 – Version number and date 

 Drag the default date object to column 3 and place it in front of the time object 

 Add a text item to Column 1 

 Type the version number, a dash, and date.   ‘Version 2.1 – 12/28/15’ 

 Font: Arial, 9 pt  

 Left justify the cell 

Footer Column 2 – Page number 

 Drag a text item to column 2 and place it in front of the Page Number object 

 Type ‘Page  ’ (add a space after Page) 

 Leave the default number style as single page number 

 Shift click the text item and the page object and change to Arial, 9pt  

 Center justify the cell 

Footer Column 3 – Run date and time 

 Right-click the date object 
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 Go to Style > Data Format 

 Format type: Date 

 Date Style: Short 

 

 

 

 

 

 

 Right-click the time object 

 Go to Style > Data Format 

 Format type: Time 

 Time Style: Short 

 Drag a text item between the date and time objects 

 Type a single space in the text box 

 Shift-click the date, text space, and time objects and change to Arial, 9pt 

 Right justify the cell 

Report Body Style 
 

The main colors on UO Cognos Enterprise published reports are dark forest green (Custom colors: R:21 G:71 

B:52) to be used for column headers and the left side of prompt tables and neutral gray (Custom colors: R:230 

G:230 B:230).  

This neutral gray is used for column summary cells and the right side of prompt tables where it is important as a 

background that allows easy visibility of the mandatory prompt red asterisk.  

Other colors may be added as needed for report clarity and emphasis if approved by data/report owner. Use the 

Style Guide at the UO Marketing Communications website for guidance:  http://brand.uoregon.edu/colors  

 Select any item in the main table, list, or crosstab and right click. Select Style, Column Titles Style. This 

selects all column title cells. 

http://brand.uoregon.edu/colors
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 In Properties, Color & Background, select the ellipsis next to Background Image and check ‘None’ and 

click OK. 

 In Properties, Color & Background, select the ellipsis next to Background Color. Select Custom Colors and 

enter: 

o Red: 21  

o Green: 71  

o Blue: 52 

o Uncheck ‘Hexidecimal value’ 

o Click Apply and OK. 

 
 

  Ctrl and or Shift click to select column footer cells. 

  In Properties, Color & Background set Background Image = ‘None’.  

  In Properties, Color & Background set Background Color, Custom Color to   

o Red: 230  

o Green: 230 

o Blue: 230 

 



   
Integrated Data and Reporting  UO Enterprise Report Standards 

Version 4 Page 9 of 22 February 10, 2016 
 

HINT: Use the Pick up Style dropper to pick up the style from one cell to another: 

  
 

o Select one cell and click the ‘Pick up Style’ dropper 

o Then select the ‘Apply Style’ dropper and click into the cell you want to change  

Report Body Pagination 
By default Cognos displays a few rows of the report and then the user may need to scroll down to see the Page 

Up/Page Down links at the bottom of the window.  This can be very frustrating to users so set the rows per page 

to 9,999. 

 Select the main table, list, or crosstab by selecting the 3 red dots in the upper left corner  

 Set the rows per page to 9,999 in Properties > Data > Rows per Page  

Column Header Text 
Data items from the data warehouse are upper case with underscores.  To make them more user friendly 

change them to upper and lower case and change to the business name defined by the data owner.  For 

instance, SUM_ENCUMBRANCES is changed to YTD Budget Committed. 

 Right-click the header and select Edit Data Item Label 

         

 Type your desired label in Data Item Label box but do not change Data Item Name 

 Data item labels can also be changed in the Properties > Data Item 
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Report Body Headers 
Finance reports often have the FOAPAL elements in a header above the main body of the report.  In this Budget 
Status example, fields used as optional parameters are reflected in the report body header.   
 

 
 

    
 
Note:  Activity and Location rows are set to hide if they are null. (If ([Query1].[ACTIVITY] is null) Then ('') Else 
('Activity: ')) 
 

 Drag a table from the toolbox to the main workspace and make it 1 column and 2 rows.  (This helps to 

keep the data locked in place when viewed as Excel or PDF.) 

 Select the main report list or crosstab by selecting the 3 red dots in the upper left corner and drag it to 

row 2 of the new table 

 Drag a new table to row 1 and make it 3 columns and 7 rows 

o Column 1 – descriptive text items 

o Column 2 – data item code 

o Column 3 – data item description 

 Set the columns widths to either pixels or percentage in Properties > Positioning > Size and Overflow.   

o You may set just the top row of each column, or shift-click to select the entire column of cells.  

o In this example, columns 1 and 2 are set to 120 pixels wide and the third column doesn’t need 

to be set. 

When data items are added to this table you may encounter this error: 
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Instead of creating a Singleton for each data item you can relate the entire page to Query 1 and then you do not 

need Singleton’s. 

 Go to the Select Ancestor up button in the Properties header bar and select Page 

 

 Go to Properties > Data > Query and select Query1, or appropriate query 

 

 Now that the table structure has been set, add the report body header text items and data items 

o Drag text items into column 1 and add descriptive text 

o Drag data item codes into column 2 

o Drag data item descriptions into column 3 

 Use the Table menu to insert or delete rows and columns as needed 

Data Formats 
Data items can be formatted by right-clicking and selecting Style > Data Format 
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Date Format 

 Format example:  07-Feb-2013 

 Format type: Date 

 Date Style: Medium 

 Date Separator: ‘-’  

 Date Ordering: Day, Month, Year  

Dollar Amount Format 

 Format example:  -4,991.10 

 Format type: Number 

 No. of Decimal Places: 2  

o Exception: Display budgets with 

no decimal places  

 Negative Sign Symbol: ‘-’ 

 Missing Value Characters (null): 0.00 

 Zero Value Characters: 0.00 

 Divide by Zero Characters: 0.00 

 Set amounts so they do not wrap, Properties > Font & Text > White Space > No wrap 

 Be sure to also set the formatting in the totals 

Percent Format 

 Format example: -12% 

 Format type: Percent 

 Cognos defaults automatically display 

percentages with a percent sign, no 

decimal places and ‘-’ for negative  

 Missing Value Characters: ‘-’ 

 Zero Value Characters: ‘-’ 

 Divide by Zero Characters: ‘-’ 

Suppress Zero Value and Null Rows 

To suppress zero values and null rows in the main table: 

 Select the main table, list, or crosstab by selecting the 3 red dots in the upper left corner  

 Go to Properties > Data > Suppression 

 Select Rows 

 Leave default checkmarks in place 

 Select OK 
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Prompt Page 

HINT: An entire prompt page, query, or formula can be copied from an existing report. This feature only works 

when using IE. 

The default prompt page has a light grey background with buttons in the footer.

 

Prompt Page Header 
 Delete the ‘Double-click to edit text’ text item and leave the header block in place 

 Select the header and change to white 

o Use the background color button  to change to white  
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 Drag a table into the header block and make it 3 columns and 1 row.  This table will be the placeholder 

for these items: 

o Column 1 – University of Oregon Logo  

o Column 2 – Report Name  

o Column 3 – Empty placeholder to center page 

Prompt Page Header Column 1 - University of Oregon Logo  

 Select column 1 and in Properties > Positioning > Size & Overflow, set the width to 33% 

 Drag an image object from the toolbox to column 1 

 Double-click the image and the Image URL window appears 

 Click Browse 

 Select UOSignature-3455.jpg and click OK 

 
 

 In Properties > Positioning > Size & Overflow, set the height to 60 px 

 Left justify the cell 

 

Prompt Page Header Column 2 - Report Name  

 Report Name 

o Drag a text item into column 2 and type the report name.  The name should be the same report 

name that users see in the Enterprise Folders. 

 Note: Do not use ReportName() formula because users change the name when saving a 

Report View 

o Font: Arial, 12 or 14 pt, (as makes sense for the length of the report name) bold  

o Center justify the cell 

Prompt Page Header Column 3 – Empty Placeholder to Center Page 

 Select column 3 and in Properties > Positioning > Size & Overflow, set the width to 33% 

Prompt Page Body 

 Select the page body and change to white  

 Drag a table into the page body and make it 3 columns and 3 rows.  This table will be the placeholder for 

these items: 

o Column 1 – Empty placeholder to center page 

o Column 2 – Parameters and Buttons 

o Column 3 – Empty placeholder to center page 

Prompt Body Column 1 – Empty Placeholder to Center Page 

 Shift-click the 3 rows in column 1 and in Properties > Positioning > Size & Overflow, set the width to 33% 
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Prompt Body Column 2 – Prompt Table and Buttons 

 Shift-click the 3 rows in column 2 and select center  

 If you already have a prompt table, drag it to row 1 in column 2. Prompt table style is discussed below. 

 Drag a table into column 2 row 3 and make it 3 columns and 1 row.  This table will be the placeholder for 

these items: 

o Column 1 – Report Help (discussed below) 

o Column 2 – Cancel Button 

o Column 3 – Finish Button 

 

 Unlock  the prompt page 

 Pull Cancel button from the prompt page footer into column 2 

o Center justify the cell 

o Select the button and make the font Arial, 11 pt, bold 

 Pull the Finish button from the prompt page footer into column 3 

o Center  justify the cell 

o Select the button and make the font Arial, 11 pt, bold 

 Delete the prompt page footer which will also delete the Back and Next buttons 

 Relock the prompt page  

Prompt Body Column 3 – Empty Placeholder to Center Page 

 Shift-click the 3 rows in column 3 and in Properties > Positioning > Size & Overflow, set the width to 33% 

Prompt Table Style 

 Select the prompt table by selecting the 3 red dots in the upper left corner  

 Table Menu >> Apply Table Style >> Contemporary 

 

 

 

 

 

 



   
Integrated Data and Reporting  UO Enterprise Report Standards 

Version 4 Page 16 of 22 February 10, 2016 
 

 

 Using this style applies a sculptured beveled edge to the prompt table, even though we do not use the 

colors associated with it. 

 

 Ctrl-click all cells in the left column and in Properties, Color & Background set Background Color to 

Custom Color: 

o Red: 21  

o Green: 71  

o Blue: 52 

o Uncheck ‘Hexidecimal value’ 

o Click Apply and OK 

 

 Ctrl-click all cells in the right column and in Properties, Color & Background set Background Color to 

Custom Color: 

o Red: 230 

o Green: 230  

o Blue: 230 

o Uncheck ‘Hexidecimal value’ 

o Click Apply and OK. 

HINT: Use the eyedropper tool to sample the colors from an existing cell. 

Parameter Formats for Financial Reports 

 Display red * indicating required prompts (Cognos default) 

 Fiscal Year, descending sort 

 Fiscal Period, ascending sort 

 Other parameters in logical order 

Parameter Formats for HR/Payroll Reports 

 
 

 Display red * indicating required prompts (Cognos default) 

 Year always the first parameter and named Calendar Year, descending sort 

 Month always the second parameter and named Pay Number, ascending sort 

 Organization, if needed, the third parameter 

 Other parameters in logical order 
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Parameter Formats for Student Reports 

 
 

 Display red * indicating required prompts (Cognos default) 

 Term always the first parameter, descending sort 

 Student Level, if needed, the second parameter  

 College, Department, Major, Minor, if needed, and in that order 

 Other parameters in logical order 

 Registered Students Only?, as the final parameter, default not checked 

Value Prompts – Code and Description 

For value prompts, use code and description whenever possible 
Example: ‘266500 (Honors College)’  
 

 Create a Data Item Expression in the query 
Example: OrgnDesc formula, [ORGANIZATION_CODE] + ' (' + [ORGANIZATION_DESC] + ')' 

 In Properties > Data set the Data Item Expression you created as the Display Value 
 

   

Value Prompts – Display Text 

Change default display text from ‘Value_Description’ to ‘Select a …’  
Example: ‘Select a Fiscal Year’  
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 Select the Fiscal Year value prompt 

 Properties > Prompt Text > Header Text 

 Select Specified text and ‘…’ 

 In Default Text type ‘Select a Fiscal Year’ 

 Repeat for Fiscal Period and other value prompts 

Text Prompts  

Set text values to allow upper or lower case entries by utilizing the Upper() function.   

 Query filters example:  

([Operating Ledger].[Operating Ledger].[ACCOUNT_INDEX] = Upper(?p_Index?))  

 Parameter display example: Upper(ParamDisplayValue('p_Index')) 
 

Optional Parameters – Java script to warn user  

If the report has more than one optional parameter, Java script must be applied so users cannot accidently 

create run-away queries.   If the Index-to-FOAPAL re-prompt is used, Java script to disable the Enter key must 

also be applied. Sample scripts are available in the Technical FAQ’s at idr.uoregon.edu. 

Report Help 
Report Help is a link to the report description, explanations about the report parameters, and additional 
information.  It is a separate report with a simple drill-through from the parameter page of the main report.  
Always set the drill-through to open Report Help in a new window. 
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HINT: Save yourself a lot of time by copying an existing report help file, rename and revise as needed. 

 Create a new report 

o Select Blank in the New window 

o Use the Course Catalog package since it has Core Data security.  This way all users, no matter 

what their security level, can view the Help files. 

 Drag a table into the workspace and make it 1 column and 4 rows 

 Drag another table into row 1 and make it 3 columns and 1 row 

o This table will be the placeholder for these items: 

 Column 1 – Empty Placeholder to Center Header  

 Column 2 – University of Oregon Logo 

 Column 3 – Empty Placeholder to Center Header 

Column 1 – Empty Placeholder to Center Page 

 Select column 1 in row 1 and in Properties > Positioning > Size & Overflow, set the width to 33% 

Column 2 – University of Oregon Logo 

 Drag an image object from the toolbox to column 2 in the first row 

 Double-click the image and the Image URL window appears 

 Click Browse 

 Select UOSignature-3455.jpg and click OK 

 In Properties > Positioning > Size & Overflow, set the height to 60 px 

 Select the cell and center  

Column 3 – Empty Placeholder to Center Page 

 Select column 3 in row 1 and in Properties > Positioning > Size & Overflow, set the width to 33% 
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Report Name + ‘Help’ 

 Select row 2 and in Properties > Positioning > Size & Overflow, set the height to 50 px 

 Set vertical alignment to bottom  and center  

 Drag a text item into row 2 and type the original report name followed by ‘ Help’ 

 Font: Arial, 14 pt, bold 

Report Definition 

 Select row 3 and in Properties > Positioning > Size & Overflow, set the height to 50 px 

 Drag a text item into row 3 and type ‘Report Definition’ 

 Font: Arial, 12 pt, bold 

HTML Item for Help Content 

Using an HTML Item allows for enhanced formatting and bulleted items. 

 Drag an HTML Item object from the toolbox to row 4 

 Paste or type the help text  

 Add “If you have questions or problems with this report, please contact the IDR team by email: 
idr@ithelp.uoregon.edu”  
 

 
 

Comments Page 
Enterprise reports can have a shelf life of many years. Other Advanced Report Writers may need to update or 

revise the report over time so it is important to document.  A Comments Page should be created for all 

Enterprise reports. This page will never render so only report writers in Report Studio can see it. 

 

 
 

mailto:idr@ithelp.uoregon.edu


   
Integrated Data and Reporting  UO Enterprise Report Standards 

Version 4 Page 21 of 22 February 10, 2016 
 

 The purpose is to list report creator/ developer comments and record updates and modifications so a 
history of report development is available for future troubleshooting and additional development. 

 
This is an example comments page from the Budget Status Organization Drill-Through report: 
 

 
 
 
 
To create a Comments Page: 
 

 Navigate to Report Pages using the Page Explorer bar 

 Drag a new page from the Toolbox into the Report Pages pane 

 Change the name to ‘Comments Page’ in the properties table 
 

 
 

 The Comments Page does not show when the report is run: 
o Click on the ellipsis in the Render Variable in the properties table for Comments Page 
o Choose <New Boolean Variable> in the variable drop down 
o Name the variable ‘Comments Page’ and click OK 
o The Report Expression dialog box will open. In the Expression Definition box type “1 = 2”. Why? 

Since 1 can never equal 2, this expression returns ‘False’. Cognos will not render an object with 
Boolean expression returning ‘False’. 

o Click OK twice 
Double click ‘Comments Page’ to open it. Drag a table into the page and set it to  4 columns and 2 rows. Set the 
first two columns to 100 px using Size & Overflow. Set the third column to 200 px.  The fourth column will fill the 
rest of the width.  
 
Add text boxes to the cells and labels to the top row: Version, Date, Name/Phone and Comments. Add text boxes 
in the other row and enter information. 
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Drill-Through Links 
 Drill-through hyperlinks should always be the expected Blue or Purple. 

 Drill-through hyperlinks can be set to not display in Excel and PDF with render variables. 

 Open the target report in a new window when it is appropriate for the report.  

 Always display the drill-through value in the headers of the target report to retain the context of the 

data.  For instance, if the user clicks Fund to drill-through then include Fund in the header. 

Graphs 

 The UO default for pie charts is ‘Pie with 3D effects and Flat Bevel’.  If you do not see this style in the 
chart selections, go to Tools menu >> Options and in the Advanced tab and uncheck ‘Use legacy chart 
authoring’. 

View as PDF 
View the report as PDF to catch any formatting issues.  Report orientation can be set to landscape for PDF.   

 File menu >> PDF Page Setup… >> Landscape  
 

Any drill-through links must be set to display the normal field, not the hyperlinked drill-through field.  When 
users select a drill-through link in the PDF then Cognos encounters errors. 

View as Excel 
View the report as Excel to catch any formatting issues.  Any drill-through links must be set to display the normal 
field, not the hyperlinked drill-through field. 
 
Transaction Detail offers a ‘raw data’ view for Excel with the headers placed in the main table so users can have 
a flattened out version of all data displayed in the report, use auto-filter or other Excel features.  This is 
accomplished with a drill-through to another report which is designed as a single table with no headers or 
footers.  The Excel link is placed in the right side of the main report header. 

Versioning 
Every report published to the Enterprise folders will be given a version number.  This version number will be 

reflected in the footer with a date.  Example: ‘Version 2.1 - 1/13’ 

Questions?  Contact Integrated Data and Reporting 
Please contact idr@ithelp.uoregon.edu with questions.  Provide as much information as you can, including a 

screenshot if an error is displayed, so we can help you as efficiently as possible.  

mailto:idr@ithelp.uoregon.edu

